Email delays
Incident Report for Mavenlink
Resolved
Sendgrid is reporting that their systems are back to normal.
Posted over 1 year ago. Nov 03, 2015 - 13:20 PST
Monitoring
We have identified a problem with our upstream email provider. For full details please follow their status page http://status.sendgrid.com/incidents/x8rz3dqgdv4x

We expect the problem to resolve shortly
Posted over 1 year ago. Nov 03, 2015 - 10:15 PST