Pandexio Post Attachment Inaccessibility
Incident Report for Mavenlink
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 23, 2017 - 15:05 PDT
Identified
We are aware of the issue with accessing post attachments and are actively working with our partner Pandexio to resolve this issue.
Posted 7 months ago. Oct 23, 2017 - 10:17 PDT