General delay in email notifications
Incident Report for Mavenlink
Resolved
This incident has been resolved.
Posted 7 months ago. May 24, 2017 - 13:22 PDT
Identified
We have identified a delay in processing of outbound email notifications, we expect the situation to be resolved shortly.
Posted 7 months ago. May 24, 2017 - 12:56 PDT