Email Delivery Delays
Incident Report for Mavenlink
Resolved
This issue has been resolved.
Posted over 1 year ago. May 20, 2016 - 14:17 PDT
Monitoring
Some customers may be experiencing email delivery delays starting at 11am PT this morning. We have identified and resolved the issue, and are monitoring to ensure all email comes through.
Posted over 1 year ago. May 20, 2016 - 13:20 PDT