Intermittent Connectivity Issues
Incident Report for Mavenlink
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 18, 2017 - 14:56 PDT
Identified
We are currently experiencing connectivity issues with an upstream network provider. The Mavenlink application is 100% available, however users may experience delays with email notification delivery, and third party integrations.

We are closely monitoring the situation, and will provide updates as the issue is resolved.
Posted about 1 month ago. Oct 18, 2017 - 14:36 PDT