Partial outage
Incident Report for Mavenlink
Resolved
This incident has been resolved.
Posted 26 days ago. Apr 30, 2019 - 15:11 PDT
Investigating
We are investigating an issue with the standard insights data loads. Some accounts are either not receiving their data or receiving it on a delayed schedule.
Posted 27 days ago. Apr 30, 2019 - 09:18 PDT
This incident affected: Mavenlink Insights.