Email Delivery Delays
Incident Report for Mavenlink
Resolved
We have confirmed that all email delays have been resolved.
Posted about 1 year ago. May 19, 2016 - 16:13 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. May 19, 2016 - 15:23 PDT
Identified
We have identified and mitigated the source of the problem, and expect emails to resume on-time delivery shortly.
Posted about 1 year ago. May 19, 2016 - 09:58 PDT
Investigating
We are investigating delays in email notification delivery.
Posted about 1 year ago. May 19, 2016 - 09:27 PDT