Email Delays
Incident Report for Mavenlink
Resolved
Outbound email queues are back online, we expect to return to normal email response times shortly.
Posted about 1 year ago. Sep 02, 2016 - 09:32 PDT
Investigating
Users may be experiencing delays receiving emails.
Posted about 1 year ago. Sep 01, 2016 - 19:51 PDT