Degraded email delivery
Incident Report for Kantata OX
Resolved
The incident has been resolved and email delivery is restored to normal rates.
Posted Sep 16, 2020 - 14:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2020 - 19:41 PDT
Identified
We have identified an issue with slow delivery of emails. While no emails will be lost, some delay in delivery can be expected. We are working to address the issue as quickly as possible.
Posted Sep 15, 2020 - 18:36 PDT
This incident affected: Kantata OX Email Delivery.