Delayed Data Loads
Incident Report for Mavenlink
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 12, 2019 - 10:05 PDT
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Apr 12, 2019 - 10:04 PDT
Investigating
At 5am PST we started experiencing degraded performance in our standard Insights loads. We are actively investigating the issue.
Posted about 1 month ago. Apr 12, 2019 - 07:32 PDT
This incident affected: Mavenlink Insights.