Minor slowdown in system performance
Incident Report for Mavenlink
Resolved
The slowness has been resolved.
Posted 8 months ago. Apr 12, 2017 - 16:18 PDT
Identified
We have identified an issue that is causing a minor slowdown in the system. We have taken steps to resolve it and expect it to be resolved within the next few minutes.
Posted 8 months ago. Apr 12, 2017 - 16:16 PDT