Downtime Feb 14th 2025

Incident Report for Kantata OX

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 11:15 PST

Identified

The issue has been identified, and repair is in progress.
Posted Feb 14, 2025 - 11:05 PST

Investigating

We are currently investigating this issue.
Posted Feb 14, 2025 - 11:00 PST
This incident affected: Kantata OX Application.