Multiple Week Ahead Emails
Incident Report for Kantata OX
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 14:57 PST
Monitoring
We are monitoring the issue.
Posted Nov 22, 2021 - 13:32 PST
Investigating
Some users received multiple Week Ahead emails from Mavenlink. We are investigating the issue.
Posted Nov 22, 2021 - 08:51 PST
This incident affected: Kantata OX Email Delivery.